Smack
  1. Smack
  2. SMACK-324

Investigate SASL issue with jabberd2 servers

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2.2
    • Component/s: None
    • Labels:
      None

      Description

      I have a little issue with this portion of code from SASLMechanism.java concerning the element

      public String toXML() {
          StringBuilder stanza = new StringBuilder();
          stanza.append("<response xmlns=\"urn:ietf:params:xml:ns:xmpp-sasl\">");
          if (authenticationText != null) {
              stanza.append(authenticationText);
          }
          else {
              // the else case should be removed
              stanza.append("=");
          }
          stanza.append("</response>");
          return stanza.toString();
      }
      

      This codes send a '=' instead of an empty response element. '=' is not a valid base64 string. This is generally the last response of a challenge so many servers don't check the additional data but some like jabberd2 check it and send an incorrect-encoding failure. I attach the corresponding exchange.

        Activity

        Matt Johnston added a comment -

        This issue seems to affect most Android xmpp clients connecting to jabberd2. BEEM have patched it http://www.beem-project.com/projects/beem/repository/revisions/786 , I can confirm it works (no built package available yet).

        Walter Ebeling added a comment -

        Looks like a patch that we want to include for RC2

        Walter Ebeling added a comment -

        Unfortunately there are report about this as being not fixed in 2.6.3.

        http://community.igniterealtime.org/message/214456#214456

        I am not sure how to deal with that.

        Robin Collier added a comment -

        Unfortunately, the fix was applied to trunk instead of the 3.2 branch so it did not get included in the 3.2.1 release. Luckily it is a simple fix, so it will be easy to apply to 3.2.2.


          People

          • Assignee:
            Robin Collier
            Reporter:
            wroot
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development