Uploaded image for project: 'Spark'
  1. Spark
  2. SPARK-1386

Privacy Plugin shouldn't load if not supported

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0
    • Fix Version/s: 2.6.1
    • Component/s: None
    • Labels:
      None

      Description

      there is no need to query the server and try to load privacy lists if the server doesn't support privacy extension.

      to identify if privacy is supported the disco#info of the server must answer with "jabber:iq:privacy" (XEP-0016)

      if it is not supported the privacy plugin should not be active

        Attachments

          Activity

            People

            Assignee:
            stytrix Holger Bergunde
            Reporter:
            stytrix Holger Bergunde
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: