Uploaded image for project: 'Openfire'
  1. Openfire
  2. OF-611

Monitoring plugin 1.3.0 is not updating IDs of older archived messages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Moved to GH
    • Affects Version/s: 3.8.0
    • Fix Version/s: None
    • Component/s: Plugins

      Description

      from the thread:

      After looking over things a bit further, it seems the new plugin uses a diffrent Id in the table ofID to store the last used conversationID. The old plugin used ID 50, the new plugin uses Id 600. This pretty much means that anyone upgrading the plugin from 1.2.0 to 1.3.0 will break their archiving if they have messages previously archived by the old plugin. All you need to do is get the value of the old conversationId marker like so:

      select id from ofID where idType=50;

      and then insert that into the new Id Type like so:

      update ofID set id=6205 where idType=600;

      This worked for my installation, you should verify that the numbers match up for yours. the DB upgrade script should do this for you, but does not.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            wroot wroot
            Votes:
            2 Vote for this issue
            Watchers:
            10 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: