Uploaded image for project: 'Openfire'
  1. Openfire
  2. OF-367

Improve linux init script to work with Ubuntu 10.04

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Incomplete
    • Affects Version/s: 3.6.4
    • Fix Version/s: None
    • Component/s: Scripts
    • Labels:
      None
    • Environment:
      Ubuntu 10.04

      Description

      from http://www.igniterealtime.org/community/message/203022

      At Ubuntu 10.04 (Lucid lynx) there changes in java engine.. Openfire's initscript checks for /usr/lib/jvm/java-1.5.0-sun and 6.0 variant, but ubuntu uses /usr/lib/jvm/default-java..

      So I made this type of modification in /etc/init.d/openfire to make openfire to work:

      if [ -z $JAVA_HOME ]

      then
      t=/usr/lib/jvm/java-1.5.0-sun && test -d $t && JAVA_HOME=$t
      t=/usr/lib/jvm/default-java && test -d $t && JAVA_HOME=$t
      fi

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              wroot wroot
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: