Uploaded image for project: 'Openfire'
  1. Openfire
  2. OF-1937

Performance problems when first LDAP server cannot be reached

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.5.0
    • Fix Version/s: 4.5.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows Openfire server, Active Directory

      Description

      Following the changes in OF-353 to support multiple LDAP servers, I've found that when Openfire is configured to use 2 LDAP servers, and the first is unreachable (in this case, because I was testing it, and switched that box off in AWS)

      Under these conditions, performance is drastically affected.

      • Auth to Admin running locally takes around 5s
      • The first load of the Users & Groups page takes around 8 minutes (subsequent loads take around 10s)
      • Users cannot authenticate via Spark

      Guus suggested I reduce the LDAP timeout from the default of 10s. Setting it to 1.5s led to much more favourable (although still slow)

      • - 75s to load Users & Groups (4s for subsequent loads)
      • User can authenticate via Spark

      The user population in these tests was around 15 LDAP users.

        Attachments

          Activity

            People

            Assignee:
            guus Guus der Kinderen
            Reporter:
            danc_surevine Dan Caseley
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: